search envelope-o feed check
Home Unanswered Active Tags New Question
user comment-o

Facing full screen mode issue on Scheduler timeline.

Asked by Akhtar Raza
3 months ago.

I'm using this code as mentioned in the documentation.

heightSpec: "Parent100Pct",

I'm using a function to make the Fullscreen view.

toggleFullScreen(codePart: HTMLElement) {
    if (screenfull.isEnabled) {
      screenfull.toggle(codePart);
    }
 }

My HTML Code

<div class="scheduler-Sec mt-0 fullscreen" [ngClass]="isClick?'column-right':''" #codePart>
        <daypilot-scheduler [config]="config" [events]="events" #scheduler></daypilot-scheduler>
    </div>
Comment posted by Akhtar Raza
3 months ago.

When content is more it's working well.

Answer posted by Dan Letecky [DayPilot]
3 months ago.

When the content doesn't fill the whole space vertically, the Scheduler displays an empty space. I see that you are using a custom CSS theme - you'll need to update it so the space below the content has the color you want.

Another option is to use heightSpec: "Max100Pct". This option extends the Scheduler height to match the content. If the content is longer than the parent element height, it will use the parent height and add a vertical scrollbar.

Comment posted by Akhtar Raza
3 months ago.

Thanks, It's work.

This question is more than 3 months old and has been closed. Please create a new question if you have anything to add.