search envelope-o feed check
Home Unanswered Active Tags New Question
user comment-o

Scheduler RowHeaderAutoFit doesn't shrink row header

Asked by Tim K.
9 months ago.

We use the DayPilot Pro Scheduler for Vue.js and have tried using RowHeaderAutoFit. Unfortunately it doesn't work as it supposed to do. When collapsing the groupings or removing them dynamically from the scheduler, the RowHeaderColumn doesn't fit automatically to the longest text. Because the longest text is shorter than before the collapse, there is much whitespace in the row header.

You can comprehend this issue by expanding and collapsing the row headers in your demo: https://aspnet.daypilot.org/demo/Scheduler/RowHeaderAutoFit.aspx

KR
Tim

Answer posted by Dan Letecky [DayPilot]
9 months ago.

Tim,

This feature was designed to only extend the width. The latest sandbox build (2021.1.4889) now includes an experimental rowHeaderWidthAutoFitShrink property which you can use to enable shrinking (set the value to false). Let me know if it doesn't work as expected.

Comment posted by Tim K.
9 months ago.

Thank's for the quick respond. The new property works as expected in the sandbox build, when setting the value to true, like this:
"rowHeaderWidthAutoFitShrink: true"
Can you predict, when the property while be released in offical version? :-)

Comment posted by Dan Letecky [DayPilot]
9 months ago.

Great, thanks for the update!

The next release is scheduled for March 1:
https://release.daypilot.org/changes/js/

This question is more than 3 months old and has been closed. Please create a new question if you have anything to add.