search envelope-o feed check
Home Unanswered Active Tags New Question
user comment-o

Drag and drop puts event in the wrong place

Asked by Anonymous
15 years ago.

Hello

Looking to buy this system for a client and am currently testing it using the demo system at http://www.daypilot.org/demo.

Tried moving some of the events, vut get a strange result. Just dragged event 6 to the left a few days and when I release it, it drops by an hour. Same happens if I try to move it up a few hours, it always drops by an hour.

I'm using IE7 if that helps.

Cheers
Simon

Comment posted by Dan Letecky
15 years ago.
That is very strange. I've checked it using IE7 (on Windows XP) and everything works as expected. Does IE indicate any JavaScript errors on that page (yellow icon in the lower left corner of the browser)? Do you have any special toolbars installed? What Windows version are you using?
Comment posted by Anonymous
15 years ago.

Hello

Thanks for getting back to me.

Just IE7 and Windows XP SP2. No toolbars installed and no javascript error either.

Did the same thing on my colleagues PC using Firefox and on my home PC using IE7 and XP.

It's really weird as no matter where you drop it, it moves it down by an hour. So if event 6 was at 12pm and we move it one day to the right, it highlights 12pm as the start date Ok, but then when you drop it drops it at 1pm.

Ace package and keen to use it for a client so hope it's something trivial.

Cheers
Simon

Comment posted by Dan Letecky
15 years ago.
Simon, thanks for an update.

If it's not working under standard conditions (and on several machines) it's a serious problem and I really want to resolve it. If you are willing to help, could you please contact me by e-mail at daypilot @ annpoint.com?

I would set up a special version of the demo with debugging messages so I can better understand what's wrong.

BTW, I did a test on several other machines with various browsers and no problem so far.
Comment posted by Dan Letecky
15 years ago.
It was a time-zone issue. The demo is now fixed and the fix will be included in the next DayPilot Pro release. Thanks for your help, Simon!
Comment posted by Dan Letecky
14 years ago.
This is problem is now fixed in DayPilot Pro 3.7.
This question is more than 3 months old and has been closed. Please create a new question if you have anything to add.